Host4Geeks - Power Outage at US East Coast Datacenter – Incident details

All systems operational

Power Outage at US East Coast Datacenter

Resolved
Major outage
Started about 1 month agoLasted about 3 hours

Affected

US-East Coast

Major outage from 11:34 AM to 12:33 PM

Updates
  • Resolved
    Resolved
    We have been notified that the issue has been resolved.
  • Identified
    Update
    The latest update is that they are still working on resolving this,
  • Identified
    Update
    We are still awaiting further updates and ETA.
  • Identified
    Identified
    We have heard back and the operator has notified that the issue has been identified and are currently working on resolving the same. We do not have an official ETA yet on the resolution.
  • Investigating
    Investigating
    Our US East Coast facility is reporting a power outage and as a result of this, all services offered out of this facility are currently inaccessible. We were waiting to hear back from the datacenter operator on this and will provide an update as soon as we have one.